SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PhpWebGallery Vendors:   phpwebgallery.net
PhpWebGallery Input Validation Flaw in 'comments.php' Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1016435
SecurityTracker URL:  http://securitytracker.com/id/1016435
CVE Reference:   CVE-2006-3476   (Links to External Site)
Updated:  Aug 12 2008
Original Entry Date:  Jul 4 2006
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 1.5.2 and prior versions
Description:   A vulnerability was reported in PhpWebGallery. A remote user can conduct cross-site scripting attacks.

The 'comments.php' script does not properly filter HTML code from user-supplied input in the before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the PhpWebGallery software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

iss4m.h at gmail.com reported this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the PhpWebGallery software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  phpwebgallery.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  PhpWebGallery Cross Site Scripting Vulnerability

Produce : PhpWebGallery <= 1.5.2
Site    : http://www.phpwebgallery.net
Problem : XSS
Greetz  : hasnaa and all friends

Moroccan Security Research Team

Vulnerable file : comments.php

Exploit :

http://localhost/phpwebgallery/comments.php?keyword=%22%3E[XSS]

http://localhost/phpwebgallery/comments.php?keyword=%22%3E%3Cscript%3Ealert('Hi+Master');%3C/script%3E

Contact  : iss4m.h@gmail.com

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC