SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   HotPlug CMS Vendors:   hotplugcms.com
HotPlug CMS Missing Input Validation Permits SQL Injection Attacks
SecurityTracker Alert ID:  1016322
SecurityTracker URL:  http://securitytracker.com/id/1016322
CVE Reference:   CVE-2006-3190   (Links to External Site)
Updated:  Oct 13 2008
Original Entry Date:  Jun 16 2006
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Exploit Included:  Yes  
Version(s): 1.0
Description:   A vulnerability was reported in HotPlug CMS. A remote user can inject SQL commands.

The scripts in '/hotplugcms/administration/tblcontent' do not properly validate user-supplied input. A remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database and gain administrative access to the target application.

A demonstration exploit value is provided:

' OR 1=1 /*

peda reported this vulnerability.

Impact:   A remote user can execute SQL commands on the underlying database.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.hotplugcms.com/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  HotPlugCMS_1.0 - SQL Injection Vulnerability

HotPlugCMS doesn't check input field values, so logging in on /hotplugcms/administration/tblcontent
is very easy with
' OR 1=1 /*
and a SQL-inject will bypass the entire authentication process.

Typical, very simple SQL Injection.

peda

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC