SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Retrospect Vendors:   EMC
EMC Retrospect Client Buffer Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016063
SecurityTracker URL:  http://securitytracker.com/id/1016063
CVE Reference:   CVE-2006-2391   (Links to External Site)
Updated:  Dec 5 2009
Original Entry Date:  May 11 2006
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in the EMC Retrospect client. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted packet to port 497 on the target system to trigger a buffer overflow and execute arbitrary code on the target system.

The Retrospect application is not affected. Only the client is affected.

EMC credits Nicolas Pouvesle from Tenable Software and Stanka Salamun from Acros Security with reporting this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued the following fixes.

Retrospect Client for Windows 7.5:

http://download.dantz.com/archives/Retro-EN_7_5_116.exe


Retrospect Client for Windows 7.0:

http://download.dantz.com/archives/RetroClient-EN_7_0_112.exe

Retrospect Client for Windows 6.5:

http://download.dantz.com/archives/RetroClient-EN_6_5_140.exe


Retrospect Client for Macintosh 6.1:

http://download.dantz.com/archives/Client_OS_X-6_1_130.dmg

Retrospect Client for Macintosh 5.1:

http://download.dantz.com/archives/Classic-Client-EN_5_1_180.sit


Retrospect Client for Linux 7.5:

(rpm) - http://download.dantz.com/archives/retroclient-75_linux.rpm

(tar) - http://download.dantz.com/archives/retroclient-75_linux.tar

Retrospect Client for Linux 7.0:

(rpm) - http://download.dantz.com/archives/retroclient-70_linux.rpm

(tar) - http://download.dantz.com/archives/retroclient-70_linux.tar

Retrospect Client for Linux 6.5:

(rpm) - http://download.dantz.com/archives/retroclient-65_linux.rpm

(tar) - http://download.dantz.com/archives/retroclient-65_linux.tar


Retrospect Client for Solaris 7.5:

(pkg) - http://download.dantz.com/archives/retroclient-75_solaris.pkg

(tar) - http://download.dantz.com/archives/retroclient-75_solaris.tar

Retrospect Client for Solaris 7.0:

(pkg) - http://download.dantz.com/archives/retroclient-70_solaris.pkg

(tar) - http://download.dantz.com/archives/retroclient-70_solaris.tar

Retrospect Client for Solaris 6.5:

(pkg) - http://download.dantz.com/archives/retroclient-65_solaris.pkg

(tar) - http://download.dantz.com/archives/retroclient-65_solaris.tar


Retrospect Client for NetWare 1.0:

http://download.dantz.com/archives/Novell-70.zip

The EMC advisory is available at:

http://kb.dantz.com/display/2n/articleDirect/index.asp?aid=9511&r=0.7104761

Vendor URL:  kb.dantz.com/display/2n/articleDirect/index.asp?aid=9511&r=0.7104761 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC