SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Apple Safari Vendors:   Apple
Safari Bug in Processing Table Rowspan Elements Let Remote Users Deny Service
SecurityTracker Alert ID:  1015982
SecurityTracker URL:  http://securitytracker.com/id/1015982
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 24 2006
Impact:   Denial of service via network
Exploit Included:  Yes  
Version(s): 2.0.3
Description:   A vulnerability was reported in Safari. A remote user can cause denial of service conditions.

A remote user can create specially crafted HTML that, when loaded by the target user, will cause the target user's system to hang.

A demonstration exploit is provided:

<HTML>
<TABLE>
<TR><TD ROWSPAN=2000000000>

The original advisory is available at:

http://www.yanux.ch/exploits/safari/bugreport_imac_g4.txt

The vendor was notified on April 23, 2006.

Yannick von Arx discovered this vulnerability.

Impact:   A remote user can cause denial of service conditions.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.apple.com/ (Links to External Site)
Cause:   Exception handling error
Underlying OS:  UNIX (macOS/OS X)

Message History:   None.


 Source Message Contents

Subject:  =?iso-8859-1?q?Apple Mac OS X Safari 2.0.3 Vulnerability?=



Apple Mac OS X Safari 2.0.3 Vulnerability
=========================================

Release Date:
April 23th, 2006

Vendor:
Apple Computer Inc.

Tested on:
iBook G4 1.2 GHz with Mac OS X 10.4.5 (Build 8H14) + all Updates from Apple except "10.4.6 Update"
iBook G4 1.33 GHz with Mac OS X 10.4.6 (Build 8I127) + all Updates from Apple
PowerMac G4 Dual 867 MHz with Mac OS X 10.4.6 (Build 8I127) + all Updates from Apple
iMac G4 800 MHz with Mac OS X 10.4.6 (Build 8I127) + all Updates from Apple

Versions affected:
Safari 2.0.3 (417.9.2) latest version under 10.4.5 (Build 8H14) and perhaps prior versions
Safari 2.0.3 (417.9.2) latest version under 10.4.6 (Build 8I127) and perhaps prior versions

Overview:
A vulnerabilitiy exists in Safari 2.0.3 (417.9.2) and perhaps in prior versions which causes the operating system to slow down SRCOD
 (Spinning Rainbow Cursor Of Death), and therefore, it's not possible to launch any applications like Terminal to kill the process.
 After several minutes Safari crashes.

Technical Details:
Create a new File with following code ...

<HTML>
<TABLE>
<TR><TD ROWSPAN=2000000000>

.. then save it as a .html file (example.html) now open it in Safari. The application takes a lot of CPU and RAM slowing down the
 operating system SRCOD (Spinning Rainbow Cursor Of Death), and it is no longer possible to use OSX even "apple" + "ALT" + "ESC" is
 working very slow!
Go around and pull the power cable out or press the startbutton for a while to shut down the computer.

For an expample klick at the link with Safari (WARNING: That crashes Safari after several minutes an first the SRCOD (Spinning Rainbow
 Cursor Of Death) is there for all the time!) http://www.yanux.ch/exploits/safari/example.html

Report:
iMac G4 800 MHz with Mac OS X 10.4.6 (Build 8I127) + all Updates from Apple
http://www.yanux.ch/exploits/safari/bugreport_imac_g4.txt

Vendor Status:
Apple has notified of this issues on 04/23/2006

Solution:
Currently no patches have been released for this vulnerability.

Discovered by:
Yannick von Arx
yannick[dot]vonarx[at]yanux[dot]ch

____________________________

e-mail:yannick.vonarx@yanux.ch
web:	www.yanux.ch



------
freemails.ch - Free Swiss E-Mails

Webhosting nach Mass bereits ab CHF 5.50: www.hostplace.ch


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC