SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Instant Messaging/IRC/Chat)  >   PCPIN Chat Vendors:   pcpin.com
PCPIN Chat Input Validation Holes Let Remote Users Inject SQL Commands and Include Local Files
SecurityTracker Alert ID:  1015968
SecurityTracker URL:  http://securitytracker.com/id/1015968
CVE Reference:   CVE-2006-1962, CVE-2006-1963   (Links to External Site)
Updated:  Nov 29 2009
Original Entry Date:  Apr 20 2006
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 5.0.4 and prior versions
Description:   rgod reported a vulnerability in PCPIN Chat. A remote user can include and execute arbitrary code on the target system. A remote user can inject SQL commands.

The software does not properly validate user-supplied input in the username field. A remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

A demonstration exploit value is provided:

") or isnull(1/0)/*

The software does not properly validate user-supplied input in the 'language' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a file on the target system. The PHP code, including operating system commands, will run with the privileges of the target web service.

A remote user can upload smilies that contain PHP code and then exploit this include file bug to execute arbitrary code on the target system.

The original advisory is available at:

http://retrogod.altervista.org/pcpin_504_xpl.html

Impact:   A remote user can execute arbitrary PHP code on the target system with the privileges of the target web service.

A remote user can execute SQL commands on the underlying database.

Solution:   No solution was available at the time of this entry.
Vendor URL:  www.pcpin.com/modules.php?name=Downloads&d_op=viewdownload&cid=1 (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  PCPIN Chat <= 5.0.4 "login/language" remote cmmnds xctn

http://retrogod.altervista.org/pcpin_504_xpl.html

rgod
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC