SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   phpFaber TopSites Vendors:   phpFaber
phpFaber TopSites Input Validation Hole in 'page' Parameter Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1015945
SecurityTracker URL:  http://securitytracker.com/id/1015945
CVE Reference:   CVE-2006-1878   (Links to External Site)
Updated:  Nov 27 2009
Original Entry Date:  Apr 17 2006
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  

Description:   A vulnerability was reported in phpFaber TopSites. A remote user can conduct cross-site scripting attacks.

The software does not properly filter HTML code from user-supplied input in the 'page' parameter before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the phpFaber TopSites software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

http://[target]/index.php?page=<script>alert(document.cookie)</script>

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the phpFaber TopSites software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.phpfaber.com/i/products/topsites/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  phpFaber TopSites Script Cross-Site Scripting

Description :

phpFaber TopSites is a feature-packed, reliable and secure Top List coded in PHP and mySQL. phpFaber TopSites has proven its reliability
 time and time again under the most active server environments. Our feature list is large, including all elements you need to easily
 maintain your list, and even make money of it. 

phpFaber TopSites can be integrated with all your favourite applications to save you the hassle of running two separate user systems.
 phpFaber TopSites includes what you expect from a Top List and much much more. It is fully customizable and doesn't require any programming
 skills! You can create your topsite just in 3 clicks! 

Vulnerable : 

http://www.example.com/index.php?page=<script>alert(document.cookie)</script>

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC