SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Linux)  >   Linux Kernel Vendors:   kernel.org
Linux Kernel Comparison Error in get_nodes() Lets Local Users Deny Service
SecurityTracker Alert ID:  1015752
SecurityTracker URL:  http://securitytracker.com/id/1015752
CVE Reference:   CVE-2006-0557   (Links to External Site)
Date:  Mar 10 2006
Impact:   Denial of service via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Linux Kernel. A local user can cause denial of service conditions.

A local user can call the get_nodes() function with specially crafted values to cause denial of service conditions. If maxnodes is set to between ((-2 * (BITS_PER_LONG - 1) and 0, the vulnerability can be triggered.

The vulnerability resides in 'mm/mempolicy.c'.

Impact:   A local user can cause the kernel to crash.
Solution:   The vendor has issued a fix, available at:

http://linux.bkbits.net:8080/linux-2.6/cset@43fa9051sxog2Snggt2j_-aUDTdMwA

Vendor URL:  www.kernel.org/ (Links to External Site)
Cause:   Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC