SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Printer)  >   Xerox WorkCentre Vendors:   Xerox
Xerox WorkCentre Multiple Bugs in ESS/Network Controller and MicroServer Web Server Permit Remote Access, Denial of Service, and Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1015648
SecurityTracker URL:  http://securitytracker.com/id/1015648
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Feb 20 2006
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Host/resource access via network, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): WorkCentre and WorkCentre Pro 232, 238, 245, 255, 265, and 275.
Description:   A vulnerability was reported in Xerox WorkCentre in the ESS/Network Controller and MicroServer Web Server. A remote user can bypass authentication. A remote user can cause denial of service conditions. A remote user can conduct cross-site scripting attacks.

The ESS/Network Controller and MicroServer Web Server components contain several vulnerabilities.

A remote user can bypass authentication or obtain unauthorized network access.

A remote user can submit a specially crafted Postscript request to cause denial of service conditions on the target system.

A remote user can create a specially crafted HTTP request that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the WorkCentre system and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Other unspecified vulnerabilities may reduce the effectiveness of some security features.

The reported vulnerabilities may allow a remote user to modify the system configuration.

WorkCentre models 232, 238, 245, 255, 265, and 275 are affected. WorkCentre Pro models 232, 238, 245, 255, 265, and 275 are affected.

Impact:   A remote user can bypass authentication or obtain unauthorized network access.

A remote user can cause denial of service conditions on the target system.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the WorkCentre system, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote user can modify the system configuration.

Solution:   The vendor has issued fixed versions (WorkCentre System Software Version 14.027.24.015; WorkCentre Pro System Software Version 13.027.24.015), required to be installed by a Xerox Customer Service representative.

The vendor's advisory is available at:

http://www.xerox.com/downloads/usa/en/c/cert_XRX06_001.pdf

Vendor URL:  www.xerox.com/downloads/usa/en/c/cert_XRX06_001.pdf (Links to External Site)
Cause:   Access control error, Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC