SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   GnuTLS Vendors:   gnutls.org
GnuTLS libtasn1 DER Decoding Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1015612
SecurityTracker URL:  http://securitytracker.com/id/1015612
CVE Reference:   CVE-2006-0645   (Links to External Site)
Date:  Feb 11 2006
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.2.10
Description:   A vulnerability was reported in gnuTLS. A remote user can cause denial of service conditions.

The gnuTLS libtasn1 component does not properly decode DER encoded data. A remote user can send a specially crafted X.509 certificate that, when parsed by an application using gnuTLS, may trigger an out-of-bounds memory access error. This may cause the application to crash.

The report indicates that it is not certain if this vulnerability will allow arbitrary code execution.

Evgeny Legerov reported this vulnerability.

Impact:   A remote user can cause an affected application to crash.
Solution:   The vendor has issued a fixed version (1.2.10), available at:
Vendor URL:  www.gnu.org/software/gnutls/security.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 11 2006 (Red Hat Issues Fix) GnuTLS libtasn1 DER Decoding Bugs Let Remote Users Deny Service
Red Hat has released a fix for Red Hat Enterprise Linux 4.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC