SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   PAM-MySQL Vendors:   pam-mysql.sourceforge.net
PAM-MySQL pam_get_item() Double Free May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1015603
SecurityTracker URL:  http://securitytracker.com/id/1015603
CVE Reference:   CVE-2006-0056   (Links to External Site)
Date:  Feb 9 2006
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 0.6.2; 0.7 - 0.7pre2
Description:   A vulnerability was reported in PAM-MySQL. A remote user can execute arbitrary code on the target system.

A remote user can supply a specially crafted password value to trigger a double-free memory error and cause PAM-MySQL to crash or potentially execute arbitrary code.

Impact:   A remote user can cause PAM-MySQL to crash or potentially execute arbitrary code.
Solution:   The vendor has issued fixed versions (0.6.2, 0.7pre3), available at:

http://sourceforge.net/project/showfiles.php?group_id=5741

Vendor URL:  sourceforge.net/forum/forum.php?forum_id=499394 (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC