SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   OpenBSD Kernel Vendors:   OpenBSD
OpenBSD Kernel dupfdopen() Bug May Let Local Users Re-open Files With Elevated Privileges
SecurityTracker Alert ID:  1015437
SecurityTracker URL:  http://securitytracker.com/id/1015437
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 5 2006
Impact:   Not specified
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.7, 3.8
Description:   A vulnerability was reported in the OpenBSD kernel in the dupfdopen() function. The impact was not specified.

A local user may be able to cause an application that has set user id (setuid) privileges to reopen certain files.

Impact:   The impact was not specified.
Solution:   The vendor has issued the following patches:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.8/common/002_fd.patch

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.7/common/008_fd.patch

Vendor URL:  www.openbsd.org/ (Links to External Site)
Cause:   Access control error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC