SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   PerlDiver Vendors:   Script Solutions
PerlDiver 'module' Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1015146
SecurityTracker URL:  http://securitytracker.com/id/1015146
CVE Reference:   CVE-2005-3066   (Links to External Site)
Date:  Nov 3 2005
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.x, 2.x
Description:   A vulnerability was reported in PerlDiver. A remote user can conduct cross-site scripting attacks.

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the PerlDiver software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

In version 1.x, the main script is affected. A demonstration exploit URL is provided:

http://[target]/[path]/perldiver.pl?testhere<SCRIPT>alert(document.domain);</SCRIPT>

In version 2.x, the 'module' parameter is affected. A demonstration exploit URL is provided:

http://[target]/[path]/perldiver.cgi?action=2020&module=<script>document.write(document.domain)</script>

The vendor was notified on September 14, 2005.

Donnie Werner of exploitlabs discovered this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the PerlDiver software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fixed version.
Vendor URL:  www.scriptsolutions.com/programs/free/perldiver/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  [Full-disclosure] perldiver

------------------------------------------------------------
      - EXPL-A-2005-014 exploitlabs.com Advisory 043 -
------------------------------------------------------------
                          -perldiver -






AFFECTED PRODUCTS
=================
Perldiver v1.x and 2.x
http://scriptsolutions.com/



OVERVIEW
========
Perl Diver digs into your server's perl installation
 and giving you the information you need and quick
 and easy to find manner.



DETAILS
=======
1. XSS

Perldiver does not properly filter malicious script content.
XSS my be inserted in the "module" parameter. ( v2.x )
or as a GET request in the main script ( v1.x )

The malicious script is the rendered and is executed
 in the context of the users brower.



POC
===

1.x
------
http://[host]/[path]/perldiver.pl?testhere<SCRIPT>alert(document.domain);</SCRIPT>


2.x
------
http://[host]/[path]/perldiver.cgi?action=2020&module=<script>document.write(document.domain)</script>

bonus vendor site vuln:
http://www.scriptsolutions.com/programs/free/perldiver/perldiver.cgi?action=2020&module=<script>document.write(document.domain)</script>



SOLUTION:
=========
vendor contact:
Sept 14, 2005
http://www.scriptsolutions.com/support/postlist.pl?Cat=&Board=DDBugs
response Sept 15, 2005


If you are a current PerlDiver user, you can either download the updated
version,
or insert the following line after my $module = param( 'module' );
in the module_detail subroutine:

   $module =~ s/^([A-Za-z0-9]|:)//g;

updated version:
http://www.scriptsolutions.com/support/showflat.pl?Board=DLPerlDiver&Number=446
http://www.scriptsolutions.com/support/files/4-446-perldiver.zip



Credits
=======
This vulnerability was discovered and researched by
Donnie Werner of exploitlabs


mail:   wood at exploitlabs.com
mail:   morning_wood at zone-h.org
-- 
web: http://exploitlabs.com
web: http://zone-h.org

orig advisory:
http://exploitlabs.com/files/advisories/EXPL-A-2005-014-perldiver.txt
_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC