SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Kerberos Vendors:   MIT
Kerberos krb5_recvauth() Double-Free Error May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1014461
SecurityTracker URL:  http://securitytracker.com/id/1014461
CVE Reference:   CVE-2005-1689   (Links to External Site)
Updated:  Jun 1 2006
Original Entry Date:  Jul 12 2005
Impact:   Execution of arbitrary code via network, Root access via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): krb5-1.4.1 and prior versions
Description:   A double-free memory vulnerability was reported in Kerberos in the krb5_recvauth() function. A remote user may be able to execute arbitrary code.

A remote user can create certain error conditions to cause the krb5_recvauth() function to free memory that has been previously freed. Arbitrary code may be executed.

If the target system is a Kerberos Key Distribution Center (KDC) host, then the entire Kerberos realm may be compromised.

The 'kpropd', 'klogind', and 'krshd' applications are affected.

The vulnerability resides in 'krb/recvauth.c'.

The vendor credits Magnus Hagander with reporting this vulnerability.

Impact:   A remote user may be able to execute arbitrary code.
Solution:   The vendor is releasing a fixed version (krb5-1.4.2), available at:

http://web.mit.edu/kerberos/index.html

Also, the following patch is available:

Vendor URL:  web.mit.edu/kerberos/advisories/MITKRB5-SA-2005-003-recvauth.txt (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 13 2005 (Sun Issues Fix) Kerberos krb5_recvauth() Double-Free Error May Let Remote Users Execute Arbitrary Code
Sun has issued a fix.
Aug 16 2005 (Apple Issues Fix) Kerberos krb5_recvauth() Double-Free Error May Let Remote Users Execute Arbitrary Code
Apple has issued a fix for Mac OS X 10.4.2.
Sep 22 2006 (HP Issues Fix for HP-UX) Kerberos krb5_recvauth() Double-Free Error May Let Remote Users Execute Arbitrary Code
HP has issued a fix for HP-UX 11.00, 11.11, and 11.23.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC