SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   WebHints Vendors:   Burgdorf, Darryl
WebHints Input Validation Bug Lets Remote Users Execute Arbitrary Commands
SecurityTracker Alert ID:  1014173
SecurityTracker URL:  http://securitytracker.com/id/1014173
CVE Reference:   CVE-2005-1950   (Links to External Site)
Updated:  Nov 2 2008
Original Entry Date:  Jun 11 2005
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.03 and prior versions
Description:   A vulnerability was reported in WebHints. A remote user can execute arbitrary commands on the target system.

The 'hints.pl' script does not properly validate user-supplied input. A remote user can supply a specially crafted URL to execute commands on the target server with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/hints.pl?|uname|

blahplok reported this vulnerability.

Impact:   A remote user can execute arbitrary commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  awsd.com/scripts/webhints/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents

Subject:  Webhints v1.03 Remote Command Execution


Hi

This is a Vulnerablity in Webhints Scripts and user can Execute command by it .

www.example.com/hints.pl?|c0mmand|

Example : www.example.com/hints.pl?|uname|

Best Regards

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC