SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   PortailPHP Vendors:   portailphp.com
PortailPHP Input Validation Error in 'id' Parameter Permits SQL Injection
SecurityTracker Alert ID:  1014036
SecurityTracker URL:  http://securitytracker.com/id/1014036
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 23 2005
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Exploit Included:  Yes  
Version(s): 1.3
Description:   A vulnerability was reported in PortailPHP. A remote user can inject SQL commands.

The script does not properly validate user-supplied input in the 'id' parameter. A remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

Some demonstration exploit URLs are provided:

http://[target]/index.php?affiche=News&id='[SQL inj]
http://[target]/index.php?affiche=File&id='[SQL inj]
http://[target]/index.php?affiche=Liens&id='[SQL inj]
http://[target]/index.php?affiche=Faq&id='[SQL inj]

CENSORED from Search Vulnerabilities Team reported this vulnerability.

Impact:   A remote user can execute SQL commands on the underlying database.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.safari-msi.com/portailphp/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  SQL injections in PortailPHP




svadvisory*5 
-------------------------------------------------------------  
 Title: SQL injections in PortailPHP                        | 
 The program: PortailPHP v 1.3                              | 
 Homepage: http://www.portailphp.com/            ------------  
 Has found: CENSORED                             | 14.05.05 | 
-------------------------------------------------------------  

The description 
-------------------------------------------------------------| 

Vulnerability has been found in parameter "id". If this variable 
Any value it is possible to replace it with a sign ' is transferred 
Since this parameter is involved in all modules, all of them 
Are vulnerable. 
It occurs because of absence of a filtration of parameter id. 

Examples 
-------------------------------------------------------------| 

http://example/index.php?affiche=News&id='[SQL inj]
http://example/index.php?affiche=File&id='[SQL inj]
http://example/index.php?affiche=Liens&id='[SQL inj]
http://example/index.php?affiche=Faq&id='[SQL inj]

The conclusion 
-------------------------------------------------------------| 

Vulnerability is found out in version 1.3, on other versions 
Did not check. Probably they too are vulnerable. 

************************************************************* 

CENSORED || Search Vulnerabilities Team || www.svt.nukleon.us 

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC