SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Pound Vendors:   Apsis GmbH
Pound Buffer Overflow in add_port() Lets Remote Users Crash the Application
SecurityTracker Alert ID:  1013824
SecurityTracker URL:  http://securitytracker.com/id/1013824
CVE Reference:   CVE-2005-1391   (Links to External Site)
Updated:  May 3 2005
Original Entry Date:  Apr 28 2005
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 1.8.3
Description:   A vulnerability was reported in Pound. A remote user can cause the application to crash.

A remote user can supply a specially crafted hostname of 2047 bytes that includes a port number specification to trigger a buffer overflow in Pound and cause the application to crash.

The vulnerability resides in the add_port() function in 'svc.c'.

[Editor's note: The report did not indicate if arbitrary code execution is possible or not.]

Steven Van Acker reported this vulnerability.

Impact:   A remote user can cause the application to crash.
Solution:   The vendor has issued a fixed version (1.8.3), available at:

http://www.apsis.ch/pound/

Vendor URL:  www.apsis.ch/pound/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC