SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Instant Messaging/IRC/Chat)  >   Gaim Vendors:   Gaim.sourceforge.net
Gaim Can Be Crashed By Remote Users Sending Invalid Jabber File Transfer Requests
SecurityTracker Alert ID:  1013645
SecurityTracker URL:  http://securitytracker.com/id/1013645
CVE Reference:   CVE-2005-0967   (Links to External Site)
Updated:  Apr 6 2005
Original Entry Date:  Apr 5 2005
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.2.1
Description:   A vulnerability was reported in Gaim in the processing of the Jabber protocol. A remote user can cause the target user's Gaim client to crash.

A remote user can send a specially crafted Gaim Jabber file transfer request to trigger an out-of-bounds memory read error and cause the target Gaim client to crash.

The vendor credits Marcus with discovering this vulnerability.

Impact:   A remote user can cause the target user's Gaim client to crash.
Solution:   The vendor has issued a fixed version (1.2.1), available at:

http://gaim.sourceforge.net/downloads.php

Vendor URL:  gaim.sourceforge.net/security/?id=15 (Links to External Site)
Cause:   Exception handling error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 14 2005 (Red Hat Issues Fix) Gaim Can Be Crashed By Remote Users Sending Invalid Jabber File Transfer Requests
Red Hat has released a fix.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC