SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   xpcd Vendors:   Knorr, Gerd
xpcd Buffer Overflow in Processing Filenames Lets Remote Users Execute Arbitrary Code With Root Privileges
SecurityTracker Alert ID:  1013162
SecurityTracker URL:  http://securitytracker.com/id/1013162
CVE Reference:   CVE-2005-0074   (Links to External Site)
Date:  Feb 11 2005
Impact:   Execution of arbitrary code via local system, Root access via local system

Version(s): 2.09 and prior versions
Description:   A vulnerability was reported in xpcd. A local user may be able to obtain root privileges.

A local user can supply specially crafted input (such as a filename) to trigger a buffer overflow to execute arbitrary code with root privileges.

The buffer overflows reside in 'test/view.c' and 'xpcd/complete.c'.

Erik Sjolund discovered these overflows.

Impact:   A local user can execute arbitrary code with root privileges.
Solution:   No solution was available at the time of this entry.
Vendor URL:  linux.bytesex.org/fbida/xpcd.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 11 2005 (Debian Issues Fix) xpcd Buffer Overflow in Processing Filenames Lets Remote Users Execute Arbitrary Code With Root Privileges
Debian has released a fix.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC