SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   BiTBOARD Vendors:   BiTSHiFTERS
BiTBOARD Input Validation Hole in BBCODE Tags Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1012864
SecurityTracker URL:  http://securitytracker.com/id/1012864
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 12 2005
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 2.5 and prior versions
Description:   An input validation vulnerability was reported in BiTBOARD. A remote user can conduct cross-site scripting attacks.

drhankey of it-security23.net reported that the software does not properly filter HTML code from user-supplied input in messages in bbcode tags. A remote user can submit specially crafted text that, when viewed by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the vulnerable software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit is provided:

[img]path/to/some/image' onMouseover='alert("hehehe... insecure");[/img]

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the BiTBOARD software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.bitshifters.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  Security Advisory: BiTBOARD xss




Advisory Information
--------------------
Advisory name		:  BiTBOARD XSS
Discovered by		:  drhankey / it-security23.net
Vendor Name		:  the bitshifters sdc
Vendor Homepage		:  http://www.bitshifters.net
Software		:  Bitboard
Vulnerability Type	:  Cross-Site-Scripting
Vulnerable Versions	:  2.5 and prior
Platforms		:  OS Independent, PHP


What is Bitshifters Bitboard?
----------------------------------
Woltlab Burning Board Lite is a free message board using plain text files as database.


Vulnerability Description:
-------------------------
Ii's possible to inject javascript by abusing some kind of bbcode used in the posting system.

Proof of Concept:
-----------------
[img]path/to/some/image' onMouseover='alert("hehehe... insecure");[/img]

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC