SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   poppassd_pam Vendors:   Gentoo
poppassd_pam Lets Remote Users Modify Arbitrary Passwords
SecurityTracker Alert ID:  1012840
SecurityTracker URL:  http://securitytracker.com/id/1012840
CVE Reference:   CVE-2005-0002   (Links to External Site)
Updated:  Jan 13 2005
Original Entry Date:  Jan 12 2005
Impact:   Modification of authentication information, Root access via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 1.0 and prior versions
Description:   A vulnerability was reported in poppassd_pam. A remote user can change the password of any target user, including the root user account.

Gentoo reported that poppassd_pam does not authenticate remote users prior to changing the system password for the remote user. As a result, a remote user can change the system password of arbitrary POP users.

Gentoo Linux developer Marcus Hanwell is credited with discovering this flaw.

Impact:   A remote user can change the system password of an arbitrary target user, including the root user account.
Solution:   Gentoo has issued a new package called poppassd_ceti to replace poppassd_pam. Gentoo indicates that all poppassd_pam users should migrate to the new package called poppassd_ceti:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-mail/poppassd_ceti-1.8.4"

Vendor URL:  www.gentoo.org/ (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-22 ] poppassd_pam: Unauthorized password changing


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigCFFCB6C8C690A212C7D1C7F7
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: poppassd_pam: Unauthorized password changing
      Date: January 11, 2005
      Bugs: #75820
        ID: 200501-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

poppassd_pam allows anyone to change any user's password without
authenticating the user first.

Background
==========

poppassd_pam is a PAM-enabled server for changing system passwords that
can be used to change POP server passwords.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /  Vulnerable  /               Unaffected
    -------------------------------------------------------------------
     net-mail/poppassd_ceti       <= 1.0                      >= 1.8.4
     net-mail/poppassd_pam        <= 1.0                   Vulnerable!
    -------------------------------------------------------------------

Description
===========

Gentoo Linux developer Marcus Hanwell discovered that poppassd_pam did
not check that the old password was valid before changing passwords.
Our investigation revealed that poppassd_pam did not call
pam_authenticate before calling pam_chauthtok.

Impact
======

A remote attacker could change the system password of any user,
including root. This leads to a complete compromise of the POP
accounts, and may also lead to a complete root compromise of the
affected server, if it also provides shell access authenticated using
system passwords.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All poppassd_pam users should migrate to the new package called
poppassd_ceti:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-mail/poppassd_ceti-1.8.4"

Note: Portage will automatically replace the poppassd_pam package by
the poppassd_ceti package.

References
==========

  [ 1 ] CAN-2005-0002
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0002

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-22.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enigCFFCB6C8C690A212C7D1C7F7
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFB5C+jvcL1obalX08RArvIAJ9ZOVPcvvmdT7oII63BXGf3hi887QCfTE6J
hQJ8vmqpcUFMHMYW7l+3DyE=
=j/cR
-----END PGP SIGNATURE-----

--------------enigCFFCB6C8C690A212C7D1C7F7--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC