SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   libmysqlclient Vendors:   MySQL.com
MySQL libmysqlclient Buffer Overflow in Executing Prepared Statements Has Unspecified Impact
SecurityTracker Alert ID:  1011408
SecurityTracker URL:  http://securitytracker.com/id/1011408
CVE Reference:   CVE-2004-2149   (Links to External Site)
Updated:  Jul 2 2005
Original Entry Date:  Sep 24 2004
Impact:   Not specified
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 4.1.5
Description:   A vulnerability was reported in MySQL in libmysqlclient. A remote authenticated user can trigger a buffer overflow. The impact was not specified.

Ken Gieselman reported that a remote authenticated user can execute bulk inserts using prepared statements containing thousands of placeholders to trigger a buffer overflow.

The original bug report is available at:

http://bugs.mysql.com/bug.php?id=5194

Impact:   The impact was not specified.
Solution:   The vendor has released a fixed development version (4.1.5), available at:

http://dev.mysql.com/downloads/mysql/4.1.html

Vendor URL:  dev.mysql.com/doc/mysql/en/News-4.1.5.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC