SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
Samba FindNextPrintChangeNotify() Error Lets Remote Authenticated Users Crash smbd
SecurityTracker Alert ID:  1011097
SecurityTracker URL:  http://securitytracker.com/id/1011097
CVE Reference:   CVE-2004-0829   (Links to External Site)
Updated:  Sep 10 2004
Original Entry Date:  Aug 31 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 3.0.6, prior to 2.2.11
Description:   A vulnerability was reported in Samba. A remote authenticated user can cause smbd to crash.

The vendor reported that a remote authenticated user can send a FindNextPrintChangeNotify() request without having previously sent a corresponding FindFirstPrintChangeNotify() requeste to cause smbd to crash.

This behavior can be triggered by a Windows XP SP2 client.

The flaw resides in printer_notify_info() in 'rpc_server/srv_spoolss_nt.c'.

Craig Huegen reported this flaw to the vendor.

Impact:   A remote authenticated user can cause smbd to crash.
Solution:   The vendor has released a fixed version (3.0.6 and 2.2.11), available at:

http://samba.org/samba/download/

Vendor URL:  samba.org/samba/history/samba-2.2.11.html (Links to External Site)
Cause:   Exception handling error, State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 9 2004 (Gentoo Issues Fix) Samba FindNextPrintChangeNotify() Error Lets Remote Authenticated Users Crash smbd
Gentoo has released a fix.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC