SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Database)  >   MySQL Vendors:   MySQL.com
MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
SecurityTracker Alert ID:  1009784
SecurityTracker URL:  http://securitytracker.com/id/1009784
CVE Reference:   CVE-2004-0388   (Links to External Site)
Date:  Apr 15 2004
Impact:   Modification of system information, Modification of user information, Root access via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 4.0.18, 3.23.58
Description:   A vulnerability was reported in the MySQL 'mysqld_multi' script. A local user may be able to gain elevated privileges on the target system.

SuSE reported that the 'mysqld_multi' shell script creates a temporary log file ('/tmp/mysqld_multi.log') in an unsafe manner. A local user can create a symbolic link (symlink) from a critical file on the system to this temporary file. Then, when the script is run by a target user, the symlinked file will be overwritten with the privileges of the target user.

A local user may be able to gain elevated privileges on the target system.

Impact:   A local user can cause files to be overwritten with the privileges of the target user. A local user may be able to gain elevated privileges on the target system.
Solution:   The vendor has issued a fixed version, which has been committed to the MySQL source repository, available at:

http://www.mysql.com/doc/en/Installing_source_tree.html

The fix is included in version 1.13 of 'scripts/mysqld_multi.sh' as of April 14, 2004.

Vendor URL:  www.mysql.com/ (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 15 2004 (Debian Issues Fix) MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
Debian has released a fix.
Apr 20 2004 (Mandrake Issues Fix) MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
Mandrake has released a fix.
May 25 2004 (Gentoo Issues Fix) MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
Gentoo has released a fix.
Oct 20 2004 (Red Hat Issues Fix) MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
Red Hat has released a fix for Red Hat Enterprise Linux 2.1.
Oct 21 2004 (Red Hat Issues Fix) MySQL 'mysqld_multi' Temporary File Flaw Lets Local Users Overwrite Files
Red Hat has released a fix for Red Hat Enterprise Linux 3.



 Source Message Contents

Subject:  CVE-2004-0388


CVE: CAN-2004-0388

A vulnerability was reported in the MySQL 'mysqld_multi' script.  A local user can 
overwrite arbitrary files on the target system.

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC