SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Git Vendors:   kernel.org
(Ubuntu Issues Fix) Git run_command() API Flaw on Linux/UNIX Lets Remote Authenticated Users Execute Arbitrary Commands on the Target System
SecurityTracker Alert ID:  1042173
SecurityTracker URL:  http://securitytracker.com/id/1042173
CVE Reference:   CVE-2018-19486   (Links to External Site)
Date:  Nov 28 2018
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.19.2
Description:   A vulnerability was reported in Git. A remote authenticated user can execute arbitrary commands on the target system.

A remote authenticated user can issue specially crafted commands from the current working directory to exploit a flaw in the run_command() API and 'run-command.c' to execute execute arbitrary commands on the target system.

Jeff King reported this vulnerability.

Impact:   A remote authenticated user can execute arbitrary commands on the target system.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://usn.ubuntu.com/usn/usn-3829-1

Vendor URL:  usn.ubuntu.com/usn/usn-3829-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 18.04 LTS, 18.10

Message History:   This archive entry is a follow-up to the message listed below.
Nov 28 2018 Git run_command() API Flaw on Linux/UNIX Lets Remote Authenticated Users Execute Arbitrary Commands on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC