SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
(Red Hat Issues Fix) nginx MP4 Processing Bug Lets Remote Users Deny Service and Disclose Potentially Sensitive Information
SecurityTracker Alert ID:  1042170
SecurityTracker URL:  http://securitytracker.com/id/1042170
CVE Reference:   CVE-2018-16845   (Links to External Site)
Date:  Nov 28 2018
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.1.3+, 1.0.7+
Description:   A vulnerability was reported in nginx. A remote user can cause denial of service conditions on the target system. A remote user can obtain potentially sensitive information on the target system.

A remote user can create a specially crafted ngx_http_mp4_module that when processed by the target system, will cause the target system to crash or cause process memory disclosure based on the MP4 file.

Nginx is only affected if it is built using the ngx_http_mp4 (i.e., not the default) and if the "mp4" directive is used in the configuration file.

Impact:   A remote user can cause denial of service conditions.

A remote user can obtain potentially sensitive information on the target system.

Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://access.redhat.com/errata/RHSA-2018:3652

Vendor URL:  access.redhat.com/errata/RHSA-2018:3652 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  6, 7, 7.4, 7.5, 7.6

Message History:   This archive entry is a follow-up to the message listed below.
Nov 7 2018 nginx MP4 Processing Bug Lets Remote Users Deny Service and Disclose Potentially Sensitive Information



 Source Message Contents

Subject:  [RHSA-2018:3652-01] Important: rh-nginx18-nginx security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: rh-nginx18-nginx security update
Advisory ID:       RHSA-2018:3652-01
Product:           Red Hat Software Collections
Advisory URL:      https://access.redhat.com/errata/RHSA-2018:3652
Issue date:        2018-11-26
CVE Names:         CVE-2018-16845 
=====================================================================

1. Summary:

An update for rh-nginx18-nginx is now available for Red Hat Software
Collections.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) - x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64

3. Description:

nginx is a web and proxy server supporting HTTP and other protocols, with a
focus on high concurrency, performance, and low memory usage.

Security Fix(es):

* nginx: Denial of service and memory disclosure via mp4 module
(CVE-2018-16845)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

Red Hat would like to thank the Nginx project for reporting this issue.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

The rh-nginx18-nginx service must be restarted for this update to take
effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

1644508 - CVE-2018-16845 nginx: Denial of service and memory disclosure via mp4 module

6. Package List:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6):

Source:
rh-nginx18-nginx-1.8.1-1.el6.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el6.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el6.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6):

Source:
rh-nginx18-nginx-1.8.1-1.el6.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el6.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el6.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-nginx18-nginx-1.8.1-1.el7.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el7.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el7.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4):

Source:
rh-nginx18-nginx-1.8.1-1.el7.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el7.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el7.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5):

Source:
rh-nginx18-nginx-1.8.1-1.el7.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el7.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el7.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6):

Source:
rh-nginx18-nginx-1.8.1-1.el7.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el7.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el7.1.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):

Source:
rh-nginx18-nginx-1.8.1-1.el7.1.src.rpm

x86_64:
rh-nginx18-nginx-1.8.1-1.el7.1.x86_64.rpm
rh-nginx18-nginx-debuginfo-1.8.1-1.el7.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-16845
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBW/viKdzjgjWX9erEAQjSFA/+IYlcY+VkhYOzot4cXoMumMPj0zcn6Iuk
TwHfLvfooC8KsM5PK3acSmv2526KlfWn9xi8QJ8YMIoZVX8+LPPC7gOVxmwAyYOn
4uOumQy5rulkk03UB7r6y7u34Xy5mftCXTOouOipvhiW2Na6aZWiRen7ZWRBcMMW
okYWY03xJU7/OQafttfP3UUVAYiw5adZ6gAflhZA8q8JzF0RhZXnliyt4kpZ1kLj
8fr6q+9WDVdiHe9u1j1wIXwQglkPnpab+kW1k4KZ3pdJMzFr9unZURHbyDsqbxlh
T5rNTFtoLO9rgksSYtkuK0D6MvxVu7MzHMl/X0IsCnFwwAjH9xbqftqX5G26pQR6
L2UlnBNnes+NG357E81aHJus6ioRpjzSsfIrFoU9N0K9llnfbEslwEr239GzF6hH
sMO5vap7/i2bmYQ7++jw9jfF67K2AtFvZCa/tYWlilkWOM12BkP2HvuYXCgmtb6F
99oHxB5TyDKPb44epIvzKV/YtvoeHT6beKRIefJ3xstrq8to0f87NZhTTbk5rYt0
HPf5vLjoZO6SYequmHzn++zoAZubU+oZ3fE05jcbrJSwQeMHWLPTtBoBkmQq+l5y
rYTxun0/RvYql6bZD4uHAxKzTxyAvrKw0dW+/DGNanQiwkk+/RpPrYTdMhVw4a5a
ZrQQucuvvOo=
=LfBW
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC