SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Git Vendors:   kernel.org
Git run_command() API Flaw on Linux/UNIX Lets Remote Authenticated Users Execute Arbitrary Commands on the Target System
SecurityTracker Alert ID:  1042166
SecurityTracker URL:  http://securitytracker.com/id/1042166
CVE Reference:   CVE-2018-19486   (Links to External Site)
Updated:  Nov 28 2018
Original Entry Date:  Nov 28 2018
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.19.2
Description:   A vulnerability was reported in Git. A remote authenticated user can execute arbitrary commands on the target system.

A remote authenticated user can issue specially crafted commands from the current working directory to exploit a flaw in the run_command() API and 'run-command.c' to execute execute arbitrary commands on the target system.

Jeff King reported this vulnerability.

Impact:   A remote authenticated user can execute arbitrary commands on the target system.
Solution:   The vendor has issued a fix (2.19.2).

https://git.kernel.org/pub/scm/git/git.git/commit/?id=321fd823

Vendor URL:  git.kernel.org/pub/scm/git/git.git/commit/?id=321fd823 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 28 2018 (Ubuntu Issues Fix) Git run_command() API Flaw on Linux/UNIX Lets Remote Authenticated Users Execute Arbitrary Commands on the Target System
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, and 18.10.



 Source Message Contents

Subject:  https://git.kernel.org/pub/scm/git/git.git/commit/?id=321fd823

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC