SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
nginx MP4 Processing Bug Lets Remote Users Deny Service and Disclose Potentially Sensitive Information
SecurityTracker Alert ID:  1042039
SecurityTracker URL:  http://securitytracker.com/id/1042039
CVE Reference:   CVE-2018-16845   (Links to External Site)
Date:  Nov 7 2018
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.1.3+, 1.0.7+
Description:   A vulnerability was reported in nginx. A remote user can cause denial of service conditions on the target system. A remote user can obtain potentially sensitive information on the target system.

A remote user can create a specially crafted ngx_http_mp4_module that when processed by the target system, will cause the target system to crash or cause process memory disclosure based on the MP4 file.

Nginx is only affected if it is built using the ngx_http_mp4 (i.e., not the default) and if the "mp4" directive is used in the configuration file.

Impact:   A remote user can cause denial of service conditions.

A remote user can obtain potentially sensitive information on the target system.

Solution:   The vendor has issued a fix (1.15.6, 1.14.1).

The vendor has issued a fix, available at:

http://nginx.org/download/patch.2018.mp4.txt

Vendor URL:  mailman.nginx.org/pipermail/nginx-announce/2018/000221.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 7 2018 (Ubuntu Issues Fix) nginx MP4 Processing Bug Lets Remote Users Deny Service and Disclose Potentially Sensitive Information
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, and 18.10.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC