SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
nginx HTTP/2 Processing Bugs Lets Remote Users Deny Service
SecurityTracker Alert ID:  1042038
SecurityTracker URL:  http://securitytracker.com/id/1042038
CVE Reference:   CVE-2018-16843, CVE-2018-16844   (Links to External Site)
Date:  Nov 7 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.9.5 - 1.15.5
Description:   Two vulnerabilities were reported in nginx. A remote user can consume excessive CPU resources on the target system. A remote user can consume excessive memory on the target system.

A remote user can issue a specially crafted HTTP/2 request to cause excessive memory consumption [CVE-2018-16843].

A remote user can issue a specially crafted HTTP/2 request to cause excessive CPU consumption [CVE-2018-16844].

Systems compiled with the ngx_http_v2_module (i.e., not the default) and with the "https" option of the "listen" directive are affected.

Gal Goldshtein from F5 Networks reported one of these vulnerabilities.

Impact:   A remote user can consume excessive CPU resources on the target system.

A remote user can consume excessive memory resources on the target system.

Solution:   The vendor has issued a fix (1.15.6, 1.14.1).
Vendor URL:  mailman.nginx.org/pipermail/nginx-announce/2018/000220.html (Links to External Site)
Cause:   Resource error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 7 2018 (Ubuntu Issues Fix) nginx HTTP/2 Processing Bugs Lets Remote Users Deny Service
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, and 18.10.
Nov 27 2018 (Red Hat Issues Fix) nginx HTTP/2 Processing Bugs Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 7, 7.4, 7.5, and 7.6.
Nov 27 2018 (Red Hat Issues Fix) nginx HTTP/2 Processing Bugs Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 7, 7.4, 7.5, and 7.6.
Nov 28 2018 (Red Hat Issues Fix) nginx HTTP/2 Processing Bugs Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 6, 7, 7.4, 7.5, and 7.6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC