SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Device (Embedded Server/Appliance)  >   Advantech Ethernet I/O Module Vendors:   Advantech
Advantech WebAccess Bugs Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1041957
SecurityTracker URL:  http://securitytracker.com/id/1041957
CVE Reference:   CVE-2018-17908, CVE-2018-17910   (Links to External Site)
Date:  Oct 25 2018
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): WebAccess 8.3.2 and prior
Description:   Two vulnerabilities were reported in Advantech WebAccess. A local user can obtain elevated privileges on the target system.

During installation, the application installer disables user-based access control until after installation is completed [CVE-2018-17908]. A local user can execute arbitrary commands on the target system with elevated privileges.

The application does not properly validate the length of user-supplied data [CVE-2018-17910]. A local user can execute arbitrary commands on the target system with elevated privileges.


Impact:   A local user can obtain elevated privileges on the target system.
Solution:   The vendor has issued a fix, available at:

http://support.advantech.com/support/DownloadSRDetail_New.aspx?SR_ID=1-MS9MJV&Doc_Source=Download

Vendor URL:  ics-cert.us-cert.gov/advisories/ICSA-18-296-01 (Links to External Site)
Cause:   Access control error, Boundary error

Message History:   None.


 Source Message Contents

Subject:  Advantech WebAccess


https://ics-cert.us-cert.gov/advisories/ICSA-18-298-02

WebAccess Versions 8.3.2 and prior.


During installation, the application installer disables user access control and does not re-enable it after the installation is complete. This could allow an attacker to run elevated arbitrary code.

CVE-2018-17908 has been assigned to this vulnerability. A CVSS v3 base score of 8.4 has been calculated; the CVSS vector string is (AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H).



The application fails to properly validate the length of user-supplied data, causing a buffer overflow condition that allows for arbitrary remote code execution.

CVE-2018-17910 has been assigned to this vulnerability. A CVSS v3 base score of 7.8 has been calculated; the CVSS vector string is (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H).




 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC