SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Mozilla Firefox Vendors:   Mozilla.org
(Red Hat Issues Fix) Mozilla Firefox Multiple Bugs Let Remote Users Deny Service, Obtain Potentially Sensitive Information, and Execute Arbitrary Code
SecurityTracker Alert ID:  1041952
SecurityTracker URL:  http://securitytracker.com/id/1041952
CVE Reference:   CVE-2018-12389, CVE-2018-12390, CVE-2018-12392, CVE-2018-12393, CVE-2018-12395, CVE-2018-12396, CVE-2018-12397   (Links to External Site)
Date:  Oct 25 2018
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions on the target system. A remote user can obtain potentially sensitive information on the target system.

On Firefox for Android, a remote user can cause audio data to be loaded in violation of service policy via HTTP Live Streaming [CVE-2018-12391].

A remote user can cause a crash with nested event loops [CVE-2018-12392].

A remote user can cause an integer overflow during Unicode conversion while loading JavaScript [CVE-2018-12393]. 64-bit builds are not affected.

A remote user can cause a WebExtension bypass of domain restrictions through header rewriting [CVE-2018-12395].

A remote user can cause a WebExtension to run disallowed scripts [CVE-2018-12396].

A remote user can cause a missing WebExtension warning prompt when requesting local file access [CVE-2018-12397].

A remote user can inject stylesheets and bypass Content Security Policy (CSP) in some special resource URLs [CVE-2018-12398].

A remote user can spoof the protocol registration notification bar [CVE-2018-12399].

On Firefox for Android, favicons are cached in private browsing mode [CVE-2018-12400].

A remote user can cause a denial of service attack when special resource URL parsing [CVE-2018-12401].

A remote user can cause SameSite cookies to leak when explicitly saved [CVE-2018-12402].

A remote user can cause a mixed content warning to be not displayed when an HTTPS page loads a favicon via HTTP [CVE-2018-12403].

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system [CVE-2018-12388, CVE-2018-12389, CVE-2018-12390].

1lastBr3ath, Abdulrahman Alqabandi, Bob Owen, Bogdan Tara, Boris Zbarsky, Calixte Denizet, Christian Holler, Dana Keeler, Daniel Veditz, Gary Kwong, Jason Kratzer, Jed Davis, Jun Kokatsu, Konark Modi, Marcia Knous, Mathias Wu, Nils, Philipp, Raul Gurzau, Raymond Forbes, Rob Wu, Andrew Swan, Ronald Crane, Steve Fink, Taegeon Lee, Tyson Smith, Yigit Can Yilmaz, cgvwzq, and r reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause denial of service conditions.

A remote user can obtain potentially sensitive information on the target system.

Solution:   Red Hat has issued a fix for CVE-2018-12389, CVE-2018-12390, CVE-2018-12392, CVE-2018-12393, CVE-2018-12395, CVE-2018-12396, and CVE-2018-12397.

The Red Hat advisory is available at:

https://access.redhat.com/errata/RHSA-2018:3006

Vendor URL:  access.redhat.com/errata/RHSA-2018:3006 (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error, State error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  6

Message History:   This archive entry is a follow-up to the message listed below.
Oct 24 2018 Mozilla Firefox Multiple Bugs Let Remote Users Deny Service, Obtain Potentially Sensitive Information, and Execute Arbitrary Code



 Source Message Contents

Subject:  [RHSA-2018:3006-01] Critical: firefox security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: firefox security update
Advisory ID:       RHSA-2018:3006-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2018:3006
Issue date:        2018-10-24
CVE Names:         CVE-2018-12389 CVE-2018-12390 CVE-2018-12392 
                   CVE-2018-12393 CVE-2018-12395 CVE-2018-12396 
                   CVE-2018-12397 
=====================================================================

1. Summary:

An update for firefox is now available for Red Hat Enterprise Linux 6.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop (v. 6) - i386, x86_64
Red Hat Enterprise Linux Desktop Optional (v. 6) - x86_64
Red Hat Enterprise Linux HPC Node Optional (v. 6) - x86_64
Red Hat Enterprise Linux Server (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 6) - x86_64
Red Hat Enterprise Linux Workstation (v. 6) - i386, x86_64
Red Hat Enterprise Linux Workstation Optional (v. 6) - x86_64

3. Description:

Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance, and portability.

This update upgrades Firefox to version 60.3.0 ESR.

Security Fix(es):

* Mozilla: Memory safety bugs fixed in Firefox 63 and Firefox ESR 60.3
(CVE-2018-12390)

* Mozilla: Crash with nested event loops (CVE-2018-12392)

* Mozilla: Integer overflow during Unicode conversion while loading
JavaScript (CVE-2018-12393)

* Mozilla: WebExtension bypass of domain restrictions through header
rewriting (CVE-2018-12395)

* Mozilla: WebExtension content scripts can execute in disallowed contexts
(CVE-2018-12396)

* Mozilla: WebExtension local file permission check bypass (CVE-2018-12397)

* Mozilla: Memory safety bugs fixed in Firefox ESR 60.3 (CVE-2018-12389)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

Red Hat would like to thank the Mozilla project for reporting these issues.
Upstream acknowledges Christian Holler, Bob Owen, Boris Zbarsky, Calixte
Denizet, Jason Kratzer, Jed Davis, Taegeon Lee, Philipp, Ronald Crane, Raul
Gurzau, Gary Kwong, Tyson Smith, Raymond Forbes, Bogdan Tara, Nils, r, Rob
Wu, Andrew Swan, and Daniel Veditz as the original reporters.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing the update, Firefox must be restarted for the changes to
take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

1642179 - CVE-2018-12389 Mozilla: Memory safety bugs fixed in Firefox ESR 60.3
1642180 - CVE-2018-12390 Mozilla: Memory safety bugs fixed in Firefox 63 and Firefox ESR 60.3
1642182 - CVE-2018-12392 Mozilla: Crash with nested event loops
1642183 - CVE-2018-12393 Mozilla: Integer overflow during Unicode conversion while loading JavaScript
1642185 - CVE-2018-12395 Mozilla: WebExtension bypass of domain restrictions through header rewriting
1642186 - CVE-2018-12396 Mozilla: WebExtension content scripts can execute in disallowed contexts
1642187 - CVE-2018-12397 Mozilla: WebExtension local file permission check bypass

6. Package List:

Red Hat Enterprise Linux Desktop (v. 6):

Source:
firefox-60.3.0-1.el6.src.rpm

i386:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

x86_64:
firefox-60.3.0-1.el6.x86_64.rpm
firefox-debuginfo-60.3.0-1.el6.x86_64.rpm

Red Hat Enterprise Linux Desktop Optional (v. 6):

x86_64:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

Red Hat Enterprise Linux HPC Node Optional (v. 6):

Source:
firefox-60.3.0-1.el6.src.rpm

x86_64:
firefox-60.3.0-1.el6.i686.rpm
firefox-60.3.0-1.el6.x86_64.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.x86_64.rpm

Red Hat Enterprise Linux Server (v. 6):

Source:
firefox-60.3.0-1.el6.src.rpm

i386:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

ppc64:
firefox-60.3.0-1.el6.ppc64.rpm
firefox-debuginfo-60.3.0-1.el6.ppc64.rpm

s390x:
firefox-60.3.0-1.el6.s390x.rpm
firefox-debuginfo-60.3.0-1.el6.s390x.rpm

x86_64:
firefox-60.3.0-1.el6.x86_64.rpm
firefox-debuginfo-60.3.0-1.el6.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6):

x86_64:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
firefox-60.3.0-1.el6.src.rpm

i386:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

x86_64:
firefox-60.3.0-1.el6.x86_64.rpm
firefox-debuginfo-60.3.0-1.el6.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 6):

x86_64:
firefox-60.3.0-1.el6.i686.rpm
firefox-debuginfo-60.3.0-1.el6.i686.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-12389
https://access.redhat.com/security/cve/CVE-2018-12390
https://access.redhat.com/security/cve/CVE-2018-12392
https://access.redhat.com/security/cve/CVE-2018-12393
https://access.redhat.com/security/cve/CVE-2018-12395
https://access.redhat.com/security/cve/CVE-2018-12396
https://access.redhat.com/security/cve/CVE-2018-12397
https://access.redhat.com/security/updates/classification/#critical
https://www.mozilla.org/en-US/security/advisories/mfsa2018-27/

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBW9DtTNzjgjWX9erEAQicqg/+LJFATp9gO18j0KICERk+sj57W9A8cxkC
J0dFp5SfiB5EAWnnt2RnZdm15a5uU+I+zI3wRVfJs9kfEQ1PUF2w82ThcnUej0nw
5rlH0tCJBb+SM/u0f5v1ohdr8HFzIq1QEF8a0rBtVS3abFjouZv2XjND5Qb6GSRQ
6N93pYvWOJRYUmicIsWLtYzk85WUVUYAAiTGPKwBkwiSyDxU8OvEgFN3CzwT3Fvt
Y2ZljC0RtqfhIruJDmKPnmCg4MHyQw81bPGzx8nAI2uR1aoOpDg7lAwgwKfrunw6
WK8elPCI9/15Wo6qaOlYe3ELaAu0mZTY3LztFffKpZOIsccz6cgsBOw5/8E9+xV4
i1R6jI4gDi/9yakTHIZwmD/hCH9tr/clJfRXQuoD88Ua7ImY9Ip8/DTq4clNdsdw
tQdx8UHeifvciF/Ayq9+qoi4tqhpgoA0wHN2i8srDfNMwxtcfVQYRH2G/bzuZdNF
0hEmx4GZtkU2lavrTjU0+/Zo/eF07Pfe94K0lYX+eiiIHnrzGKgcbll4DCiR8jxT
0wdSkWszpa+YlaxerjwnBSlrkRGIx0kt7pHabToPWSbbedhAdITxBNF/IXEqKrOX
EnjKMujXV6wof5gLOQhIOM43McN8cRTSw8TwkqAqG1MyGIcOaU5xbLZj3HtRitqa
jgAdlnFinTE=
=9GlI
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC