SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   IBM Business Process Manager Vendors:   IBM
IBM Business Process Manager Input Validation Flaw Lets Remote Authenticated Users Inject SQL Commands
SecurityTracker Alert ID:  1041717
SecurityTracker URL:  http://securitytracker.com/id/1041717
CVE Reference:   CVE-2018-1674   (Links to External Site)
Date:  Sep 25 2018
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.5, 8.5.0.1, 8.5.0.2, 8.5.5, 8.5.6, 8.5.6.1, 8.5.6.2, 8.5.7.CF201606, 8.5.7.CF201609, 8.5.7.CF201612, 8.5.7.CF201703, 8.5.7.CF201706, 8.5.7, 8.6.0.CF201712, 8.6.0.CF201803, 8.6, 18.0.0.0, 18.0.0.1
Description:   A vulnerability was reported in IBM Business Process Manager. A remote authenticated user can inject SQL commands.

The software does not properly validate user-supplied input. A remote authenticated user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

Impact:   A remote authenticated user can execute SQL commands on the underlying database.
Solution:   IBM has issued a fix (APAR JR59569).

The IBM advisory is available at:

https://www-01.ibm.com/support/docview.wss?uid=ibm10720035

Vendor URL:  www-01.ibm.com/support/docview.wss?uid=ibm10720035 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (Solaris - SunOS), Windows (Any), z/OS

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC