SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   MediaWiki Vendors:   wikipedia.sourceforge.net
MediaWiki Multiple Flaws Let Remote Authenticated Users Bypass Security Restrictions and Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1041695
SecurityTracker URL:  http://securitytracker.com/id/1041695
CVE Reference:   CVE-2018-0503, CVE-2018-0504, CVE-2018-0505, CVE-2018-13258   (Links to External Site)
Date:  Sep 21 2018
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Several vulnerabilities were reported in MediaWiki. A remote authenticated user can bypass security restrictions. A remote user can obtain potentially sensitive information on the target system.

The '$wgRateLimits' rate limiter entry for 'user' overrides the setting for 'newbie' users [CVE-2018-0503]. A remote authenticated user can bypass intended limits.

When a log event is partially hidden, a remote authenticated user can access potentially sensitive information via the 'Special:Redirect/logid' function [CVE-2018-0504].

A remote authenticated user with permissions to change user rights can bypass certain security controls on the target system [CVE-2018-0505].

The version 1.31 tar archive is missing '.htaccess' files [CVE-2018-13258].

Rxy and JJMC89 reported some of these vulnerabilities.

Impact:   A remote authenticated user can bypass security controls on the target system.

A remote authenticated user can obtain potentially sensitive information on the target system.

Solution:   The vendor has issued a fix (1.27.5, 1.29.3, 1.30.1, 1.31.1).

The vendor advisory is available at:

https://lists.wikimedia.org/pipermail/mediawiki-announce/2018-September/000223.html
https://phabricator.wikimedia.org/T169545
https://phabricator.wikimedia.org/T194605
https://phabricator.wikimedia.org/T187638
https://phabricator.wikimedia.org/T199029

Vendor URL:  lists.wikimedia.org/pipermail/mediawiki-announce/2018-September/000223.html (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC