SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VoIP)  >   Asterisk Vendors:   Digium (Linux Support Services)
Asterisk Stack Overflow in HTTP Websocket Upgrade Lets Remote Users Cause the Target Service to Crash
SecurityTracker Alert ID:  1041694
SecurityTracker URL:  http://securitytracker.com/id/1041694
CVE Reference:   CVE-2018-17281   (Links to External Site)
Date:  Sep 21 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 13.x, 14.x, 15.x
Description:   A vulnerability was reported in Asterisk. A remote user can cause the target service to crash.

A remote user can send a specially crafted HTTP request to request an HTTP websocket upgrade that triggers a stack overflow in the 'res_http_websocket.so' module and causes the target service to consume all available stack memory.

Sean Bright reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (13.23.1, 14.7.8, 15.6.1).

The vendor advisory is available at:

http://downloads.asterisk.org/pub/security/AST-2018-009.html

Vendor URL:  downloads.asterisk.org/pub/security/AST-2018-009.html (Links to External Site)
Cause:   Resource error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC