SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (Linux)  >   Linux Kernel Vendors:   kernel.org
Debian Linux MOTD Update Script Unsafe Temporary File Usage Lets Local Users Deny Service and Gain Elevated Privileges
SecurityTracker Alert ID:  1041530
SecurityTracker URL:  http://securitytracker.com/id/1041530
CVE Reference:   CVE-2018-6557   (Links to External Site)
Date:  Aug 21 2018
Impact:   Denial of service via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): Ubuntu 18.04 LTS
Description:   A vulnerability was reported in the Debian Linux base system file MOTD update script. A local user can cause denial of service conditions on the target system. A local user can obtain elevated privileges on the target system.

The MOTD update script does not properly process temporary files. A local user can create specially crafted symbolic links (symlinks) from a temporary file to a critical file on the system to overwrite files with administrator privileges.

The 'base-files' package is affected.

Impact:   A local user can cause denial of service conditions on the target system.

A local user can obtain elevated privileges on the target system.

Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://usn.ubuntu.com/usn/usn-3748-1

Vendor URL:  usn.ubuntu.com/usn/usn-3748-1 (Links to External Site)
Cause:   Access control error, State error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC