SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Oracle Java SE Vendors:   Oracle, Sun
(CentOS Issues Fix) Oracle Java SE Multiple FLaws Let Remote Users Access and Modify Data, Deny Service, and Gain Elevated Privileges
SecurityTracker Alert ID:  1041439
SecurityTracker URL:  http://securitytracker.com/id/1041439
CVE Reference:   CVE-2018-2952   (Links to External Site)
Date:  Aug 9 2018
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6u191, 7u181, 8u172, 10.0.1
Description:   Multiple vulnerabilities were reported in Oracle Java SE. A remote user can gain elevated privileges. A remote user can access and modify data on the target system. A remote user can cause denial of service conditions on the target system.

A remote user can exploit a flaw in the Java SE Java DB component to gain elevated privileges [CVE-2018-2938].

A remote user can exploit a flaw in the Java SE Deployment component to gain elevated privileges [CVE-2018-2964].

A remote user can exploit a flaw in the Java SE JavaFX component to gain elevated privileges [CVE-2018-2941].

A remote user can exploit a flaw in the Java SE Windows DLL component to gain elevated privileges [CVE-2018-2942].

A remote user can exploit a flaw in the Java SE Security component to access data [CVE-2018-2972].

A remote user can exploit a flaw in the Java SE Embedded JSSE component to modify data [CVE-2018-2973].

A remote user can exploit a flaw in the Java SE Embedded Libraries component to partially access data [CVE-2018-2940].

A remote user can exploit a flaw in the Java SE Embedded JRockit Concurrency component to cause partial denial of service conditions [CVE-2018-2952].

Daniel Bleichenbacher of Google, Gregory Draperi, Sidney Markowitz, and Zhong Zhaochen reported some of these vulnerabilities.

Impact:   A remote user can obtain data on the target system.

A remote user can modify data on the target system.

A remote user can cause denial of service conditions.

A remote user can gain elevated privileges on the target system.

Solution:   CentOS has issued a fix for CVE-2018-2952.

i386:
5d7c23cc5f6490644f30cc874eff9b0376be8f5e5142d3000530457422a20257 java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.i686.rpm
62bd98fda4c2d74b249097a2083dcf37ca36addf20a6668ab3e3f7a43bd66d66 java-1.7.0-openjdk-demo-1.7.0.191-2.6.15.4.el6_10.i686.rpm
3c2234d7f8a74105abf76e0c6ea66f385cf4083ac942063a25350f3cdabf4528 java-1.7.0-openjdk-devel-1.7.0.191-2.6.15.4.el6_10.i686.rpm
f86b24613cb373d57bd9994321392d59455f9b951159d8d0d5a5a2cff4117923 java-1.7.0-openjdk-javadoc-1.7.0.191-2.6.15.4.el6_10.noarch.rpm
a5833c2e102a05273e6306283d332cbee2f84b4e008aaaa60fda760cd5ab3535 java-1.7.0-openjdk-src-1.7.0.191-2.6.15.4.el6_10.i686.rpm

x86_64:
1aa0cd7801ce78a765ec56e20af38882e540ca9c96d245ebc3ceb41636e1ef80 java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.x86_64.rpm
74fad258b6a399f9cb9ad6eed044bff17d46ebfbb49631ee364af3695539fb66 java-1.7.0-openjdk-demo-1.7.0.191-2.6.15.4.el6_10.x86_64.rpm
7ce0a0c40b879461f0155bd5666c03bed02ac7da2a29a214d48bbcec7e59e9cd java-1.7.0-openjdk-devel-1.7.0.191-2.6.15.4.el6_10.x86_64.rpm
f86b24613cb373d57bd9994321392d59455f9b951159d8d0d5a5a2cff4117923 java-1.7.0-openjdk-javadoc-1.7.0.191-2.6.15.4.el6_10.noarch.rpm
c3440b525d7fc9a8aa20607b596e480104dfb1d6b8d78b5a862c9cf75051ef5e java-1.7.0-openjdk-src-1.7.0.191-2.6.15.4.el6_10.x86_64.rpm

Source:
011b1cc84bde6a7a0652f63d63f20b9a05004b7ab91e61303e9d875e08f4c9c6 java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.src.rpm

x86_64:
eaf8b440d4d9616ec42e57ddf421871fa4f9a8e60f0c69446f2ec22e80c7b283 java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
63db95d992e429d779e8a1a0cd74173148b0da3f83025fe325ab802fba26aa35 java-1.7.0-openjdk-accessibility-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
479c06d62bf85cd7b18a82456d85288ce62f5fe17e30dab177710155f2bbc849 java-1.7.0-openjdk-demo-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
ec352aae5f47c1b86d88b9572dd0b4de2aabc915c830924b318f34c1b7d1f6c7 java-1.7.0-openjdk-devel-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
13cf6c95028f06dc2c4f25040e0eb2b626ef4ddea1a3ab46c9fb788137b37596 java-1.7.0-openjdk-headless-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
2a6f4e573d7362e301cebc9efd96ffcb64849a04aecc6fd48161ddd50cdccc0a java-1.7.0-openjdk-javadoc-1.7.0.191-2.6.15.4.el7_5.noarch.rpm
dad5d7f6805279dd705280e36aa3659a024543aed1308e052ed5cd6e5dfa8291 java-1.7.0-openjdk-src-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm

Source:
18786ff0a7eaf41146df9f010de77790c39f3f8e0b11bdf2e2b1a32bf744d07b java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el7_5.src.rpm

Cause:   Not specified
Underlying OS:  Linux (CentOS)
Underlying OS Comments:  6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Jul 17 2018 Oracle Java SE Multiple FLaws Let Remote Users Access and Modify Data, Deny Service, and Gain Elevated Privileges



 Source Message Contents

Subject:  [CentOS-announce] CESA-2018:2286 Moderate CentOS 7 java-1.7.0-openjdk Security Update


CentOS Errata and Security Advisory 2018:2286 Moderate

Upstream details at : https://access.redhat.com/errata/RHSA-2018:2286

The following updated files have been uploaded and are currently 
syncing to the mirrors: ( sha256sum Filename ) 

x86_64:
eaf8b440d4d9616ec42e57ddf421871fa4f9a8e60f0c69446f2ec22e80c7b283  java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
63db95d992e429d779e8a1a0cd74173148b0da3f83025fe325ab802fba26aa35  java-1.7.0-openjdk-accessibility-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
479c06d62bf85cd7b18a82456d85288ce62f5fe17e30dab177710155f2bbc849  java-1.7.0-openjdk-demo-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
ec352aae5f47c1b86d88b9572dd0b4de2aabc915c830924b318f34c1b7d1f6c7  java-1.7.0-openjdk-devel-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
13cf6c95028f06dc2c4f25040e0eb2b626ef4ddea1a3ab46c9fb788137b37596  java-1.7.0-openjdk-headless-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm
2a6f4e573d7362e301cebc9efd96ffcb64849a04aecc6fd48161ddd50cdccc0a  java-1.7.0-openjdk-javadoc-1.7.0.191-2.6.15.4.el7_5.noarch.rpm
dad5d7f6805279dd705280e36aa3659a024543aed1308e052ed5cd6e5dfa8291  java-1.7.0-openjdk-src-1.7.0.191-2.6.15.4.el7_5.x86_64.rpm

Source:
18786ff0a7eaf41146df9f010de77790c39f3f8e0b11bdf2e2b1a32bf744d07b  java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el7_5.src.rpm



-- 
Johnny Hughes
CentOS Project { http://www.centos.org/ }
irc: hughesjr, #centos@irc.freenode.net
Twitter: @JohnnyCentOS

_______________________________________________
CentOS-announce mailing list
CentOS-announce@centos.org
https://lists.centos.org/mailman/listinfo/centos-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC