SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Django Vendors:   djangoproject.com
Django Open Redirect Flaw in CommonMiddleware Lets Remote Users Redirect the Target User's Browser to an Arbitrary Site
SecurityTracker Alert ID:  1041403
SecurityTracker URL:  http://securitytracker.com/id/1041403
CVE Reference:   CVE-2018-14574   (Links to External Site)
Date:  Aug 1 2018
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Django. A remote user can redirect the target user's browser to an arbitrary site.

On systems with django.middleware.common.CommonMiddleware and the APPEND_SLASH setting enabled and with a project that has a URL pattern that accepts any path ending in a slash, a remote user can create a URL that, when loaded by the target user, will redirect the target user's browser to an arbitrary site.

Andreas Hug reported this vulnerability.

Impact:   A remote user can cause the target user's browser to be redirected to an arbitrary web site.
Solution:   The vendor has issued a fix (1.11.15, 2.0.8).

The vendor advisory is available at:

https://www.djangoproject.com/weblog/2018/aug/01/security-releases/

Vendor URL:  www.djangoproject.com/weblog/2018/aug/01/security-releases/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Aug 1 2018 (Ubuntu Issues Fix) Django Open Redirect Flaw in CommonMiddleware Lets Remote Users Redirect the Target User's Browser to an Arbitrary Site
Ubuntu has issued a fix for Ubuntu Linux 18.04 LTS.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC