SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Apache Tomcat Vendors:   Apache Software Foundation
Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
SecurityTracker Alert ID:  1041375
SecurityTracker URL:  http://securitytracker.com/id/1041375
CVE Reference:   CVE-2018-1336   (Links to External Site)
Date:  Jul 26 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0.28 to 7.0.88, 8.0.0.RC1 to 8.0.51, 8.5.0 to 8.5.30, 9.0.0.M1 to 9.0.7
Description:   A vulnerability was reported in Apache Tomcat. A remote user can cause denial of service conditions on the target system.

A remote user can send specially crafted data containing supplementary characters to trigger an overflow in the UTF-8 decoder and cause the target service to enter an infinite loop.

Impact:   A remote user can cause the target service to enter an infinite loop.
Solution:   The vendor has issued a fix (7.0.88, 8.0.52, 8.5.31, 9.0.8).

The vendor advisories are available at:

https://tomcat.apache.org/security-7.html
https://tomcat.apache.org/security-8.html
https://tomcat.apache.org/security-9.html

Vendor URL:  tomcat.apache.org/security-9.html (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 26 2018 (Ubuntu Issues Fix for Apache Tomcat) Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
Ubuntu has issued a fix for Apache Tomcat for Ubuntu Linux 14.04 LTS and 16.04 LTS.
Sep 14 2018 (Red Hat Issues Fix for Red Hat JBoss) Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat JBoss for Red Hat Enterprise Linux 6 and 7.
Oct 16 2018 (Red Hat Issues Fix) Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 7.
Oct 16 2018 (Oracle Issues Fix for Oracle Linux) Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
Oracle has issued a fix for Oracle Linux 7.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC