SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Xen Vendors:   Xen Project
Xen Lets Local Administrative Users on a Guest System Write to Read-Only Disks in Certain Cases
SecurityTracker Alert ID:  1041203
SecurityTracker URL:  http://securitytracker.com/id/1041203
CVE Reference:   CVE-2018-12892   (Links to External Site)
Date:  Jun 28 2018
Impact:   Modification of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.6.x, 4.7.x, 4.8.x, 4.9.x
Description:   A vulnerability was reported in Xen. A local administrative user on the guest system can write to read-only SCSI disks in certain cases.

A local administrative user on the guest system can exploit a flaw in libxl to bypass the read-only restrictions on a SCSI disk image in certain cases.

Emulated SCSI disks are affected. IDE disks are not affected.

Systems using qemu-xen as the device model version are affected.

Systems using libxl or libxl-based toolstacks (e.g., xl, libvirt with the libxl driver) are affected.

Andrew Reimers of OrionVM reported this vulnerability.

Impact:   A local administrative user on the guest system can write to read-only SCSI disks in certain cases.
Solution:   The vendor has issued a fix.

The vendor advisory is available at:

https://xenbits.xen.org/xsa/advisory-266.html

Vendor URL:  xenbits.xen.org/xsa/advisory-266.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC