SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache ZooKeeper Vendors:   Apache Software Foundation
Apache ZooKeeper Lack of Quorum Peer Mutual Authentication Lets Remote Users Modify Data on the Target System
SecurityTracker Alert ID:  1040948
SecurityTracker URL:  http://securitytracker.com/id/1040948
CVE Reference:   CVE-2018-8012   (Links to External Site)
Date:  May 21 2018
Impact:   Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.4.10
Description:   A vulnerability was reported in Apache ZooKeeper. A remote user can modify data on the target system in certain cases.

The system does not require authentication for a remote server to join a quorum. A remote server can join the cluster and propagate changes to the cluster leader.

Foldi Tamas and Eugene Koontz reported this vulnerability.

Impact:   A remote quorum peer can modify data on the target cluster leader.
Solution:   The vendor has issued a fix that allows Quorum Peer mutual authentication to be enabled (3.4.10).

The vendor advisory is available at:

http://zookeeper.apache.org/security.html#CVE-2018-8012

Vendor URL:  zookeeper.apache.org/security.html#CVE-2018-8012 (Links to External Site)
Cause:   Authentication error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC