SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Dhcp Vendors:   ISC (Internet Software Consortium)
Red Hat DCHP NetworkManager Script Component Lets Remote Users on the Local Network Execute Arbitrary Commands with Root Privileges on the Target System
SecurityTracker Alert ID:  1040912
SecurityTracker URL:  http://securitytracker.com/id/1040912
CVE Reference:   CVE-2018-1111   (Links to External Site)
Date:  May 15 2018
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Red Hat DHCP. A remote user on the local network can execute arbitrary commands on the target system.

A remote user on the local network can return specially crafted data via dhcp to trigger a command injection flaw in the NetworkManager integration script included in the DHCP client packages in Red Hat Enterprise Linux to execute execute arbitrary commands on the target system. The commands will run with root privileges.

A remote DHCP server or a remote user that can spoof a DHCP server can exploit this flaw.

Felix Wilhelm (Google Security Team) reported this vulnerability.

Impact:   A remote user on the local network can execute arbitrary commands on the target system.
Solution:   Red Hat has issued a fix.

The Red Hat advisories are available at:

https://access.redhat.com/security/vulnerabilities/3442151
https://access.redhat.com/errata/RHSA-2018:1453
https://access.redhat.com/errata/RHSA-2018:1454
https://access.redhat.com/errata/RHSA-2018:1455
https://access.redhat.com/errata/RHSA-2018:1456
https://access.redhat.com/errata/RHSA-2018:1457
https://access.redhat.com/errata/RHSA-2018:1458
https://access.redhat.com/errata/RHSA-2018:1459
https://access.redhat.com/errata/RHSA-2018:1460
https://access.redhat.com/errata/RHSA-2018:1461

Vendor URL:  access.redhat.com/security/vulnerabilities/3442151 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  6, 6.4, 6.5, 6.6, 6.7, 7, 7.2, 7.3, 7.4

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 15 2018 (Oracle Issues Fix for Oracle Linux) Red Hat DCHP NetworkManager Script Component Lets Remote Users on the Local Network Execute Arbitrary Commands with Root Privileges on the Target System
Oracle has issued a fix for Oracle Linux 6 and 7.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC