SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Web Server/CGI)  >   IBM InfoSphere Information Server Vendors:   IBM
(IBM Issues Fix for IBM InfoSphere Information Server) OpenSSL Overflow in rsaz_1024_mul_avx2() Lets Remote Users Obtain Potentially Sensitive Information in Certain Cases and SSL_read()/SSL_write() Error State Bug May Bypass Decryption/Encryption in Certain Application Dependent Cases
SecurityTracker Alert ID:  1040764
SecurityTracker URL:  http://securitytracker.com/id/1040764
CVE Reference:   CVE-2017-3738   (Links to External Site)
Date:  Apr 27 2018
Impact:   Disclosure of authentication information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.1, 11.3, 11.5, 11.7
Description:   Two vulnerabilities were reported in OpenSSL. A remote user can obtain potentially sensitive information on the target system in certain cases. A remote user may be able to cause an application to bypass decryption/encryption in certain limited cases. IBM InfoSphere Information Server is affected.

A remote user can exploit an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli to potentially determine information about the private key in certain situations [CVE-2017-3738].

Processors that support the AVX2 but not ADX extensions (e.g., Intel Haswell (4th generation)) are affected.

Attacks against DH1024 may be feasible.

EC algorithms are not affected.

A remote user can invoke a handshake failure to trigger a bug in OpenSSL error handling code for applications that directly make an SSL_read() or SSL_write() call for an SSL object after receiving a fatal error, causing data to bypass the decryption or encryption process [CVE-2017-3737]. Versions 1.0.2b and after are affected.

David Benjamin (Google) reported these vulnerabilities.

Impact:   A remote user can potentially determine information about the private key in certain situations.

A remote user may be able to cause an application to bypass decryption/encryption in certain limited cases.

Solution:   IBM has issued a fix for CVE-2017-3738 for IBM InfoSphere Information Server (APAR JR59108).

The IBM advisory is available at:

http://www-01.ibm.com/support/docview.wss?uid=swg22015215

Vendor URL:  www-01.ibm.com/support/docview.wss?uid=swg22015215 (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 7 2017 OpenSSL Overflow in rsaz_1024_mul_avx2() Lets Remote Users Obtain Potentially Sensitive Information in Certain Cases and SSL_read()/SSL_write() Error State Bug May Bypass Decryption/Encryption in Certain Application Dependent Cases



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC