SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Microsoft Excel Vendors:   Microsoft
Microsoft Excel File Multiple Object Memory Handling Flaws Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1040652
SecurityTracker URL:  http://securitytracker.com/id/1040652
CVE Reference:   CVE-2018-0920, CVE-2018-1011, CVE-2018-1027, CVE-2018-1029   (Links to External Site)
Date:  Apr 10 2018
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2007 SP3, 2010 SP2, 2013 SP1, 2013 RT SP1, 2016, 2016 Click-to-Run (C2R); 2016 for Mac; Office Compatibility Pack SP3; Excel Viewer 2007 SP3
Description:   Several vulnerabilities were reported in Microsoft Excel. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted file that, when loaded by the target user, will trigger an object memory handling flaw and execute arbitrary code on the target user's system [CVE-2018-0920]. Version 2010 SP2 is affected

A remote user can create a specially crafted file that, when loaded by the target user, will trigger an object memory handling flaw and execute arbitrary code on the target user's system [CVE-2018-1011]. Versions 2010 SP2, 2013 SP1, and 2013 RT SP1 are affected.

A remote user can create a specially crafted file that, when loaded by the target user, will trigger an object memory handling flaw and execute arbitrary code on the target user's system [CVE-2018-1027]. Versions 2007 SP3, 2010 SP2, 2013 SP1, and 2013 RT SP1 are affected.

A remote user can create a specially crafted file that, when loaded by the target user, will trigger an object memory handling flaw and execute arbitrary code on the target user's system [CVE-2018-1029]. Version 2007 SP3 is not affected.

Vladislav Stolyarov of Kaspersky Lab, Steven Seeley (mr_me) of Source Incite (via Trend Micros Zero Day Initiative), and Jaanus Kaap of Clarified Security reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix.

The Microsoft advisories are available at:

https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-0920
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-1011
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-1027
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-1029

Vendor URL:  portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-0920 (Links to External Site)
Cause:   Access control error
Underlying OS:  UNIX (macOS/OS X), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC