SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
Apache HTTPD Header Processing Bug Lets Remote Users Cause the Target Service to Crash
SecurityTracker Alert ID:  1040573
SecurityTracker URL:  http://securitytracker.com/id/1040573
CVE Reference:   CVE-2018-1301   (Links to External Site)
Date:  Mar 26 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.1 to 2.4.29
Description:   A vulnerability was reported in Apache HTTPD. A remote user can cause the target service to crash.

A remote user can send a specially crafted HTTP request to trigger an out-of-bounds memory access error after a header size limit has been reached to cause the target service to crash.

Robert Swiecki reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (2.4.30).

The vendor advisory is available at:

http://httpd.apache.org/security/vulnerabilities_24.html#CVE-2018-1301

Vendor URL:  httpd.apache.org/security/vulnerabilities_24.html#CVE-2018-1301 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  CVE-2018-1301: Possible out of bound access after failure in reading the HTTP request


CVE-2018-1301: Possible out of bound access after failure in reading the HTTP request

Severity: Low

Vendor: The Apache Software Foundation

Versions Affected:
httpd 2.0.1 to 2.4.29

Description:
A specially crafted request could have crashed the Apache HTTP Server prior to
version 2.4.30, due to an out of bound access after a size limit is reached by
reading the HTTP header. This vulnerability is considered very hard if not
impossible to trigger in non-debug mode (both log and build level), so it is
classified as low risk for common server usage.

Mitigation:
All httpd users should upgrade to 2.4.30 or later.

Credit:
The issue was discovered by Robert Swiecki, bug found by honggfuzz

References:
https://httpd.apache.org/security/vulnerabilities_24.html
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC