SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
SecurityTracker Alert ID:  1040493
SecurityTracker URL:  http://securitytracker.com/id/1040493
CVE Reference:   CVE-2018-1050   (Links to External Site)
Date:  Mar 13 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.0.0 and after
Description:   A vulnerability was reported in Samba. A remote user can cause the target print spooler service to crash.

A remote user can send specially crafted RPC calls to the 'spoolss' service to trigger a null pointer error and cause the target print spooler service to crash.

Systems configured with the the 'spoolss' service as an external daemon are affected.

Impact:   A remote user can cause the target print spooler service to crash.
Solution:   The vendor has issued a fix (4.5.16, 4.6.14, 4.7.6).

The vendor advisory is available at:

https://www.samba.org/samba/security/CVE-2018-1050.html

Vendor URL:  www.samba.org/samba/security/CVE-2018-1050.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 13 2018 (Ubuntu Issues Fix) Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, and 17.10.
Mar 26 2018 (Ubuntu Issues Fix) Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
Ubuntu has issued a fix for Ubuntu Linux 12.04 ESM.
Apr 5 2018 (HPE Issues Fix for HPE NonStop Server) Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
HPE has issued a fix for HPE NonStop Server.
Jun 20 2018 (Red Hat Issues Fix) Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Jun 20 2018 (Red Hat Issues Fix) Samba Input Validation Flaw Lets Remote Users Cause the Target Print Spooler Service to Crash
Red Hat has issued a fix for Red Hat Enterprise Linux 6.



 Source Message Contents

Subject:  https://www.samba.org/samba/security/CVE-2018-1050.html

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC