SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   IBM Security Guardium Vendors:   IBM
(IBM Issues Fix for IBM Security Guardium) MySQL Multiple Flaws Let Remote Users Gain Elevated Privileges, Modify Data, and Deny Service and Let Remote and Local Users Access Data on the Target System
SecurityTracker Alert ID:  1040350
SecurityTracker URL:  http://securitytracker.com/id/1040350
CVE Reference:   CVE-2017-10155, CVE-2017-10165, CVE-2017-10167, CVE-2017-10227, CVE-2017-10268, CVE-2017-10276, CVE-2017-10279, CVE-2017-10283, CVE-2017-10284, CVE-2017-10286, CVE-2017-10294, CVE-2017-10296, CVE-2017-10311, CVE-2017-10313, CVE-2017-10314, CVE-2017-10320, CVE-2017-10365, CVE-2017-10378, CVE-2017-10379, CVE-2017-10384   (Links to External Site)
Date:  Feb 8 2018
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.0, 9.1, 9.5
Description:   Multiple vulnerabilities were reported in MySQL. A remote or local user can access data on the target system. A remote user can modify data on the target system. A remote user can cause denial of service conditions on the target system. A remote user can gain elevated privileges. IBM Security Guardium is affected.

A remote user can exploit a flaw in the Monitoring: Web component to gain elevated privileges [CVE-2017-10424].

A remote user can exploit a flaw in the Server: Pluggable Auth component to cause denial of service conditions [CVE-2017-10155].

A remote authenticated user can exploit a flaw in the Client programs component to access data [CVE-2017-10379].

A remote authenticated user can exploit a flaw in the Server: DDL component to cause denial of service conditions [CVE-2017-10384].

A remote authenticated user can exploit a flaw in the Server: FTS component to cause denial of service conditions [CVE-2017-10276].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2017-10167, CVE-2017-10378].

A remote user can exploit a flaw in the Connector/Net component to partially access and partially modify data [CVE-2017-10277].

A remote user can exploit a flaw in the Connector/Net component to cause partial denial of service conditions [CVE-2017-10203].

A remote authenticated user can exploit a flaw in the Server: Performance Schema component to cause denial of service conditions [CVE-2017-10283].

A remote authenticated user can exploit a flaw in the Group Replication GCS component to cause denial of service conditions [CVE-2017-10313].

A remote authenticated user can exploit a flaw in the Server: DML component to cause denial of service conditions [CVE-2017-10296].

A remote authenticated user can exploit a flaw in the Server: FTS component to cause denial of service conditions [CVE-2017-10311].

A remote authenticated user can exploit a flaw in the Server: InnoDB component to cause denial of service conditions [CVE-2017-10286, CVE-2017-10320].

A remote authenticated user can exploit a flaw in the Server: Memcached component to cause denial of service conditions [CVE-2017-10314].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2017-10227, CVE-2017-10279, CVE-2017-10294].

A remote authenticated user can exploit a flaw in the Server: Replication component to cause denial of service conditions [CVE-2017-10165].

A remote authenticated user can exploit a flaw in the Server: Stored Procedure component to cause denial of service conditions [CVE-2017-10284].

A local user can exploit a flaw in the Server: Replication component to access data [CVE-2017-10268].

A remote authenticated user can exploit a flaw in the Server: InnoDB component to partially modify data and cause partial denial of service conditions [CVE-2017-10365].

Joshua Graham of Datacom TSS and Christopher Tarquini reported some of these vulnerabilities.

Impact:   A remote user can obtain data on the target system.

A remote user can modify data on the target system.

A remote user can cause denial of service conditions.

A local user can obtain data on the target system.

A remote user can gain elevated privileges on the target system.

Solution:   IBM has issued a fix for CVE-2017-10155, CVE-2017-10165, CVE-2017-10167, CVE-2017-10227, CVE-2017-10268, CVE-2017-10276, CVE-2017-10279, CVE-2017-10283, CVE-2017-10284, CVE-2017-10286, CVE-2017-10294, CVE-2017-10296, CVE-2017-10311, CVE-2017-10313, CVE-2017-10314, CVE-2017-10320, CVE-2017-10365, CVE-2017-10378, CVE-2017-10379, and CVE-2017-10384 for IBM Security Guardium.

The IBM advisory is available at:

http://www-01.ibm.com/support/docview.wss?uid=swg22012410

Vendor URL:  www-01.ibm.com/support/docview.wss?uid=swg22012410 (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any)

Message History:   This archive entry is a follow-up to the message listed below.
Oct 17 2017 MySQL Multiple Flaws Let Remote Users Gain Elevated Privileges, Modify Data, and Deny Service and Let Remote and Local Users Access Data on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC